Stream down, Drexel-wide network outage
Incident Report for WKDU Philadelphia 91.7FM
Resolved
Stream service has been restored.

According to Drexel IT, Internet Access for the Campus Network was restored to regular operation as of April 21st at 1:50 AM.
Posted Apr 21, 2021 - 02:00 EDT
Investigating
Our web stream is currently down. All network services hosted on Drexel's campus seem to be affected.
Posted Apr 20, 2021 - 22:53 EDT
This incident affected: Services (FM Broadcast, Web Streams).