Outage reported as of 1PM
Incident Report for WKDU Philadelphia 91.7FM
Resolved
Service has been restored as of 3:55PM.
Posted Aug 25, 2020 - 15:57 EDT
Investigating
An outage of the FM and online stream has been reported as of 1PM today. We are unable to restore these services remotely and are currently investigating the cause.
Posted Aug 25, 2020 - 13:10 EDT
This incident affected: Services (FM Broadcast, Web Streams).