Website outage
Incident Report for WKDU Philadelphia 91.7FM
Resolved
The website appears to be back online although DreamHost's service outage status has not been resolved or updated. https://www.dreamhoststatus.com/
Posted Sep 06, 2022 - 21:07 EDT
Identified
An outage has been reported by our website hosting provider Dreamhost. They are currently working on a fix. https://www.dreamhoststatus.com/
Posted Sep 06, 2022 - 15:22 EDT
This incident affected: Websites (WKDU.org).