Unknown outage
Incident Report for WKDU Philadelphia 91.7FM
Resolved
A power outage was noted at 4:48PM today which knocked our broadcast offline. Power was restored around 5:50PM and the stream and FM broadcast are now back online.
Posted Jun 07, 2021 - 17:57 EDT
Investigating
An unknown outage has knocked our web stream and FM broadcast offline. We will be investigating shortly.
Posted Jun 07, 2021 - 17:36 EDT
This incident affected: Services (FM Broadcast, Web Streams).