Power outage
Incident Report for WKDU Philadelphia 91.7FM
Resolved
Power outage at the station around 3AM this morning caused most of our equipment to go offline. Stream and FM went down at this time. We came back online at 10:30AM.
Posted Mar 01, 2021 - 10:30 EST
Investigating
Stream and FM offline.
Posted Mar 01, 2021 - 02:51 EST
This incident affected: Services (FM Broadcast, Web Streams).